Hacker GitHub

← All repos

becarpenter/book6

View on GitHub ↗ ★ 452 TeX

A collaborative IPv6 book

8 mentions on Hacker News by 4 people: 2 stories, 6 comments · first 2024-09-16 · latest 2026-07-13

Mentions per year 8 mentions · busiest year 2026 (7)
20082026
  1. …You have to change the version number. 2. You have to add new code to handle the new version. "" * https://github.com/becarpenter/book6/blob/main/01.%20Introdu... And this also includes 'accessory protocols': DNS A records are fixed at…
  2. …DUAL | 32 | 64 | 64 | |------|------|------| NEW | XX | 64 | 64 | ---------------------- * https://github.com/becarpenter/book6/blob/main/01.%20Introdu... There's no way around it: a non-IPng-having node will have to go through a…
  3. …as 6to4 [RFC3056, RFC3068] and Teredo [RFC4380], which have now been overtaken by events. """ * https://github.com/becarpenter/book6/blob/main/01.%20Introdu... * Interview with author of article: https://www.youtube.com/watch?v=W3jkZ1Ulz-s
  4. …been known for more than 30 years [RFC1671], although people still sometimes try to deny it. """ * https://github.com/becarpenter/book6/blob/main/01.%20Introdu... It is impossible for IPv4 to connect to IPv6: IPv4 data structures have…
    comment by throw0101a · 2026-06-24 · in Google Hits 50% IPv6
  5. …as 6to4 [RFC3056, RFC3068] and Teredo [RFC4380], which have now been overtaken by events. """ * https://github.com/becarpenter/book6/blob/main/01.%20Introdu... The people who created IPv6 weren't stupid: if you think you've thought up of a…
    comment by throw0101a · 2026-06-21 · in Google Hits 50% IPv6
  6. …been known for more than 30 years [RFC1671], although people still sometimes try to deny it. """ * https://github.com/becarpenter/book6/blob/main/01.%20Introdu... Any IPv4+ idea that "just" adds more address bits will same issues we've…
    comment by throw0101a · 2026-06-21 · in Google Hits 50% IPv6
  7. ▲ 71
    Why IPv6 is so complicated
    story by speckx · 2026-04-29 · 3 comments
  8. ▲ 1
    A Collaborative IPv6 Book
    story by mooreds · 2024-09-16 · 0 comments